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The Teacher Program Manager (TPM)

OVERVIEW

Merit Software is used in different settings and can be customized for your needs. The Teacher Program

Manager is a centralized utility program that lets you control the options and view the student records for

all the Merit Software installed on your system. Each unit of a Merit Software program stores information

in its own record file.  By using the TPM you can manage student names, view/print records and control

the customizable options.  You may access the records of any units students are not currently playing.

ACCESS THE TEACHER PROGRAM MANAGER

The Teacher Program Manager (TPM) does not have an icon on your Start menu. To access the TPM

begin any unit of a Merit program. At the title screen, instead of pressing the "Start" button, hold the Ctrl

key and press T. Type the password in the password box and press OK.

You may also access the TPM by double-clicking the TPM.exe. The TPM.exe is located in the TPM folder

within the MeritAV folder. In a network installation the MeritAV folder will be on the server.

The default location for the TPM.exe is  …\Meritav\TPM

PASSWORD

You must enter a password to use the TPM. Merit Software is shipped with a TPM password, that you

can find below the installation password on the license agreement. The TPM password is used for all

Merit Software programs teacher functions, including adding class codes at the Logon screen. Please use

appropriate security for your password. We recommend that schools change the password to protect the

security of their records. To customize the password, use the Change Password option under the File

menu. All instructors use the same password.

ADDING STUDENT NAMES TO THE RECORD DATABASE

There are two options for adding student names to the record database.

• Teacher controlled – appropriate for most schools. Names added with the TPM Set Up Student

Names functions. See the CLASS MANAGEMENT section of this manual.

• Student controlled – for home users and for mature students. Names added at the Logon Screen.

See the STUDENT ADDS OWN NAME TO THE RECORD DATABASE section of this manual.
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CLASS MANAGEMENT – STEPS FOR PRE-ENROLLING STUDENTS

CLASS LIST

Before you open the TPM you must create or locate your list of student names and class codes in a

properly formatted .txt or .csv file. The file must have each student name on a separate line. Either

commas, tabs, or semi colons can be used to separate the fields.

For example:

First Name,Last Name,Class Code

To see a sample class list file in this format double-click on class1.txt in the TPM folder.

Default location \MeritAV\TPM\class1.txt

To make your own class list from this file:

1. Double-click on class1.txt to open the file in Notepad.

2. In Notepad go to the File menu and select Save As. We recommend that you “Save in:” the

TPM folder. Name your file and make sure to give it a .txt extension.

3. Type in your student names and class codes using the names in the file as a guide.

4. Delete the sample names before you save and close the file.

5. The file must not contain any extra tabs or returns. You can check that your file has no extra

characters by opening it in Microsoft Word with the Show paragraph option active (paragraph

marker symbol depressed).

To see a tab delimited text file see the class2.txt file in the TPM folder. You may also create your file

using a word processor or Excel. If you use these programs you must save the file as .txt or .csv.

Continue with the save even if you are warned that you will lose formatting.

CREATE RECORD FILES

Each unit of a Merit Software program stores information in its own database record file or .MAV file.

These files must be created in order to use any of the Manage Student Names functions. To create .MAV

files, use the Create MAV Files option under the File menu. A wizard will help you create .MAV files for all

Merit Software on your system. The wizard detects the main applications directory or MeritAV folder that

contains subfolders with all your Merit Software. The .MAV creation process activates and then exits each

Merit Software unit. This process will not harm existing .MAV files, but may take a few minutes if you have

several Merit programs installed.  If you wish, you may create .MAV files for just one Merit Software

program at a time by navigating to its folder.
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SET LOCATION OF RECORD FILES

If the location of the record files was not set during the installation, a dialog box will appear to allow you to

select path options.  Use Help to guide your selection. Your selection will become the default

configuration for all Merit Software programs that you subsequently install to your machine. For a detailed

explanation please see pages 3 – 6 of the Merit Software Network Installation Guide.

OPEN AN .MAV FILE

To open a file, click on the Open icon, click on Open under the File menu, or use the keyboard shortcut,

Control key and “O” key. Navigate to an .MAV file and click open. If you selected “Current” for the location

of your record files, the .MAV files will be in the program folders inside your MeritAV folder. If you selected

“Literal” for the location of your record files, the .MAV files will be in the designated folder.

SET UP STUDENT NAMES

The Set Up Student Names functions become active once an .MAV file is opened. To access these

functions click on Set Up Student Names under the File menu. You can chose from the following

submenu choices:

Import from File

Export to MAV File(s)

Export to CSV File

IMPORT FROM FILE

A step by step wizard will help you import a class list from a .csv or .txt file. The file must have each

student name on a separate line. Comma, tab, or semi colon delimiters may be used.

For example:

First Name,Last Name,Class Code

If you need help formatting a file see class1.txt, class2.txt, and class.csv in the TPM folder. You can

create your file using Notepad, Excel, or any Word Processor.

NOTE: Names may be added to a class at any time by making them into a properly formatted class list

and importing them.

EXPORT TO MAV FILE(S)

A step-by-step wizard will help you export the student names and class codes to other Merit Software

Program units. Please note there must be an .MAV file for each unit to which you want to export names.
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EXPORT TO CSV FILE

A step-by-step wizard will help you export student names to a .csv file. This function is useful if you wish

to edit a class list before importing it to another unit. For example, change the Class Codes or add or

delete students.

SET LOGON SCREEN PREFERENCES

If you wish to prevent students from being able to add new names at the Logon Screen, you can remove

the New Student button in the Program Options dialog box. To access, click on Program Options under

the File menu, click on the Program Options icon, or use the keyboard shortcut, Ctrl + Alt + P. Uncheck

the “Allow New Student to add name” box.

The “Allow New Student to add name” box must be checked to enable students to add their names at the

Logon Screen.

STUDENT ADDS OWN NAME TO THE RECORD DATABASE – PREPARATION STEPS

LOGON SCREEN PREFERENCE

Confirm that the New Student button is visible at the Logon Screen. This is the default setting for newly

installed software. If the New Student button is not visible, you must open the .MAV file for the unit,

access the Program Options, and check the “Allow New Student to add name” box. See the PROGRAM

OPTIONS section of this manual.

ADD CLASS CODES

If you wish to use class codes, you must set up class codes before students’ log on to the program for the

first time. At the Logon screen of each program, click the Add Class codes button. Type the TPM

password in the password box and press OK. Class codes can be added and deleted.

Deleting student names and class codes

At the end of the semester delete the students from the TPM interface. Then return to the program Logon

screen to delete the class codes. Click the Add Class codes button. Use the Delete key to delete codes.

STUDENTS LOG ON

Students use the New Student button to add his/her own name to the record database the first time they

logon to each program unit.
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ACCESSING .MAV FILES

All .MAV files will be kept according to the configuration setup; see the Location of Record Files section of

this TPM guide. There are three ways to open a unit’s .MAV record file in the TPM.

1. Hold the Ctrl key and press the T at the title screen of the unit you wish to view. (Ctrl + T)

2. Search for *.MAV files with Search or Find on the Start menu to get a listing of all .MAV files on

your system. Double-click the .MAV file for the unit you wish to view.

3. Double-click the TPM.exe icon (default install is …\Meritav\TPM) and navigate to the .MAV file of

the program unit you wish to view.

Type the password in the password box and press OK.

SCORING

In addition to the end of round progress-to-date report that the student can print from the summary

screens, detailed scores of how a student does for each of the Main Menu parts is presented in the

Teacher Program Manager (TPM). A Student's record file keeps track of the student's name, class code,

dates played, total rounds, and skill scores for each part played. Process writing programs display

student’s work-to-date. The program also tracks the cumulative time used and the average time per

session for each student.

DISPLAY OVERVIEW

To comfortably view data on the screen we recommend that the TPM be used with a screen resolution of

1024 x 768 or higher.

When you open a unit’s record file in the TPM you are presented with the Progress-to-Date report for all

students enrolled in the unit. This report shows the overall score each student has achieved for each play

type in the program. With the color-coded Progress overview column you can easily view which play

types each student has accessed and passed. Color fills in to show a play type was accessed. An oval

shows a play type was passed. A diamond in the Finals shows that one or more skills were not passed

but an overall passing grade was achieved.

To work with the data from one class use the Select Class drop down menu to select the class you wish

to view. To see other configurations of data you can use the Select Report drop down menu. Reports

may be sorted by clicking the column top of the field you wish to sort by.
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By default, the bottom half of the screen displays the Student Detail report for the student name

highlighted in the top portion of the screen. To move the highlight you may click on a student name, use

the up and down arrow keys, or use Find (Ctrl+F) from the Student menu.

The first column of the Student Detail lists the skills covered in the unit. The next columns show the play

types in the program. You can see the percentage score for each skill for each play type in the program

by looking at a skill row. You may select a play type by clicking its column top. This will also sort the skill

scores for that play type so you can easily see the skills in the order of student proficiency for the play

type. Skills that a student has not passed in the selected play type are indicated by red text. To resort the

scores in the opposite order click the column top again. The right side of the Student Detail panel shows

an interactive graph of the skills for the selected play type.

The Student Detail display may be toggled off and on by using Ctrl+T or selecting, “Hide/Show Student

Detail Panel” from the Student menu.

The highlighted student's Daily Grade is displayed in a panel at the bottom of the screen. For each day it

shows the student's average score for the day and the amount of time played that day. To see the Daily

Grade report for all the students in the selected class, use the Select Report drop-down menu.

PRINTING
To print, click on the print icon or under the file menu, select “Print Student Data” or use Ctrl+P.

First the “Print Setup” dialog lets you select your printer, paper, and orientation. Next, the “Select what to

print” dialog appears. By default the selected class and selected report will print out. The radio buttons in

the first column let you limit the printed report to “Marked” student(s) or to the currently selected student.

The radio buttons in the second column let you choose which report to print for the selected students.

You can select between the report shown on the screen, the Student Detail report, or the Daily Grade

report.

TPM FUNCTION TOOLS

For details about the functions of the TPM press the question mark icon or use the Help menu to access

the TPM Help file. All the functions of the TPM are available by using the three menus: File, Column, and

Student. Many of the functions are also available on the Icon Menu Bar. The two drop down menus on

the upper right, Select Class and Select Report enable you to select the students and data you wish to

view.
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PROGRAM OPTIONS

The Program Options may be accessed from the Menu Bar or the File menu. You can set preferences for

sounds and graphics. You may set the program to limit the number of minutes it can be inactive before it

automatically shuts down.

You control students’ ability to add new names at the program Logon screen. To prevent students from

entering new names, uncheck the “Allow New Student to add name” box. This will remove the “New

Student” button from the Logon screen.

Some options are program specific. If an option can be adjusted it will appear in the Program Options

screen.

EXPORT STUDENT DATA

Under the File menu select Export Student Data to export the records to a CSV file. The file headings

may be excluded and the student identity may be hidden. Any spreadsheet program such as Excel can

open the file. The export function allows teachers and researchers to analyze student performance in a

format other than the Teacher Program Manager.

LOCATION OF RECORD FILES

We recommend that the location of the record files be set during installation. For a detailed explanation

please see pages 3 – 6 of the Merit Software Network Installation Guide.

The first time a Merit Software program is played on a computer, a dialog box appears indicating which

path options can be selected. Click the help button for information to guide your selection.

“Current” will store the .MAV files in the program folders inside your Merit folder.

“Literal” will store the .MAV files in the folder you designate.

Your selection will become the default configuration for all Merit Software programs that you subsequently

install to your machine. Changes can be made by using a text editor to edit the meritav.ini file in the

MeritAV folder, or by deleting the meritav.ini file and resetting the location of the record files in the dialog

box when you next sign in to a Merit Software program.

NUMBER OF STUDENTS ACCOMODATED IN RECORD FILES

The evaluation version and the home version of the program permit entry of only two student names.

When a third name is entered, the first one will be deleted. The stand-alone version for one station

contains record keeping for 42 students. Other School versions permit entry of 1,000 names.
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